DDoS Mitigation
Incident Report for AcentraMC
Resolved
This incident has been resolved.
Posted Sep 05, 2021 - 13:58 UTC
Identified
Our mitigation service kicked in due to a DDoS attack, you won't be able to connect.
Posted Sep 05, 2021 - 13:31 UTC
This incident affected: MInecraft Network (Europe Proxy).